WordPress 2.1.1 unsafe, Update to 2.1.2 – San Francisco

WordPress 2.1.1 unsafe, Update to 2.1.2 – San Francisco

Lengthy tale brief: If you downloaded and install WordPress 2.1.1 within the previous 3-4 days, your data might consist of a safety and security manipulate that was included by a biscuit, as well as you need to update every one of your data to 2.1.2 promptly.

Longer description: Today we obtained a note to our safety and security mailing address regarding uncommon as well as very exploitable code in WordPress. The concern was explored, as well as it showed up that the 2.1.1 download had actually been customized from its initial code. We took the internet site down promptly to examine what occurred.

It was figured out that a biscuit had actually acquired user-level accessibility to among the web servers that powers wordpress.org, as well as had actually made use of that accessibility to change the download documents. We have actually secured down that web server for additional forensics, however right now it shows up that the 2.1.1 download was the only point touched by the strike. They customized 2 data in WP to consist of code that would certainly permit remote PHP implementation.

This is the example you hope never ever occurs, however it did as well as currently we’re handling it as ideal we can. Although not all downloads of 2.1.1 were influenced, we’re proclaiming the whole variation unsafe as well as have actually launched a new version 2.1.2 that consists of small updates as well as completely validated data. We are likewise taking great deals of actions to guarantee something similar to this can not take place once more, not the least of which is specifically outside confirmation of the download bundle so we’ll recognize promptly if something fails for any type of factor.

Ultimately, we reset passwords for a variety of customers with SVN as well as various other gain access to, so you might require to reset your password on the forums prior to you can login once more.

What You Can Do to Aid

If your blog site is running 2.1.1, please upgrade promptly as well as do a complete overwrite of your old data, specifically those in wp-includes. Have a look at your good friends blog sites as well as if any one of them are running 2.1.1 decrease them a note as well as, if you can, lend a hand as well as assist them with the upgrade.

If you are a host or network manager, block accessibility to “theme.php” as well as “feed.php”, as well as any type of inquiry string with “ix=” or “iz=” in it. If you’re a client at a host, you might intend to send them a note to allow them learn about this launch as well as the above info.

Many Thanks to Ryan, Barry, Donncha, Mark, Michael, as well as Dougal for resolving the evening to determine as well as resolve this issue, as well as many thanks to Ivan Fratric for reporting it to begin with.

Inquiries as well as Responses

Due to the very uncommon nature of this occasion as well as launch, we have actually established an e-mail address 21securityfaq@wordpress.org that you can email inquiries to, as well as we’ll be upgrading this entrance with even more info throughout the day.

Is variation 2.0 influenced?

No downloads were changed other than 2.1.1, so if you have actually downloaded and install any type of variation of 2.0 you need to be great.

What happens if we upgrade from SVN?

Absolutely Nothing in the Subversion database was touched, so if you update as well as keep your blog site by means of SVN there is no opportunity you downloaded and install the damaged launch documents.


Cogknockers is a San Francisco WordPress Development Agency with 20+ Years Experience.  WordPress Design is at the core of our services.

Share this post

Share on facebook
Share on twitter
Share on linkedin
Share on pinterest
Share on print
Share on email

Recent News

0

Scroll to Top